centos安装 python 2.7

由于程序需要用到python,而centos自带的python 2.4版本太低了,而yum命令只支持python 2.4 ,所以就另外安装一个python 2.7

下载编译安装python 2.7

因为yum依赖python2.4,所以要修改一下yum

将文件开始的

改成

这样就可以继续使用yum命令了。

5 Comments

Add a Comment
  1. 我是不覆盖系统环境,通过virtualenv来处理python版本不同的情况

    1. 请问virtualenv怎么安装不同版本,virtualenv 创建新环境时已经默认安装了python,怎么控制安装不同版本

  2. 其实搞linxu的人我一直认为很牛

Leave a Reply

Your email address will not be published. Required fields are marked *

猫言猫语 © 2007-2014 Frontier Theme