简单的llmp(Litespeed+mysql+php)安装教程

(时间比较急,难免有错误)

Litespeed是商业软件的,但也有免费版,而且免费版功能都很强大了,其中的实时查看每个站的链接数,实时查看每个站的in/out的流量大小.这2个功能就已经非常讨我喜欢了…更多功能,自己安装体验吧,下面是安装教程.

我选择的操作系统是CentOS,mysql版本5.1.50,php版本为5.3.3

首先用yum命令安装,升级所需的程序库

yum -y install yum-fastestmirror
yum -y update
yum -y remove httpd
yum -y install patch make gcc gcc-c++ gcc-g77 flex bison tar
yum -y install libtool libtool-libs kernel-devel autoconf213
yum -y install libjpeg libjpeg-devel libpng libpng-devel
yum -y install freetype freetype-devel libxml2 libxml2-devel zlib zlib-devel
yum -y install file glib2 glib2-devel bzip2 diff* openldap-devel
yum -y install bzip2-devel ncurses ncurses-devel curl curl-devel e2fsprogs
yum -y install e2fsprogs-devel krb5 krb5-devel libidn libidn-devel
yum -y install openssl openssl-devel vim-minimal unzip vixie-cron
yum -y install fonts-chinese scim-chewing scim-pinyin scim-tables-chinese
export PHP_AUTOCONF=/usr/bin/autoconf-2.13
export PHP_AUTOHEADER=/usr/bin/autoheader-2.13


这里是安装PHP 5.2.3所需的支持库:

wget -c http://catlnmp.googlecode.com/files/libiconv-1.13.1.tar.gz
tar zxvf libiconv-1.13.1.tar.gz
cd libiconv-1.13.1/
./configure --prefix=/usr/local
make
make install
cd ../


wget -c http://catlnmp.googlecode.com/files/libevent-1.4.14b-stable.tar.gz
tar zxvf libevent-1.4.14b-stable.tar.gz
cd libevent-1.4.14b-stable/
./configure --prefix=/usr
make
make install
cd ../


wget -c http://catlnmp.googlecode.com/files/libmcrypt-2.5.8.tar.gz
tar zxvf libmcrypt-2.5.8.tar.gz
cd libmcrypt-2.5.8/
./configure
make
make install
/sbin/ldconfig
cd libltdl/
./configure --enable-ltdl-install
make
make install
cd ../../


wget -c http://catlnmp.googlecode.com/files/mhash-0.9.9.9.tar.gz
tar zxvf mhash-0.9.9.9.tar.gz
cd mhash-0.9.9.9/
./configure
make
make install
cd ../


ln -s /usr/local/lib/libmcrypt.la /usr/lib/libmcrypt.la
ln -s /usr/local/lib/libmcrypt.so /usr/lib/libmcrypt.so
ln -s /usr/local/lib/libmcrypt.so.4 /usr/lib/libmcrypt.so.4
ln -s /usr/local/lib/libmcrypt.so.4.4.8 /usr/lib/libmcrypt.so.4.4.8
ln -s /usr/local/lib/libmhash.a /usr/lib/libmhash.a
ln -s /usr/local/lib/libmhash.la /usr/lib/libmhash.la
ln -s /usr/local/lib/libmhash.so /usr/lib/libmhash.so
ln -s /usr/local/lib/libmhash.so.2 /usr/lib/libmhash.so.2
ln -s /usr/local/lib/libmhash.so.2.0.1 /usr/lib/libmhash.so.2.0.1
ln -s /usr/local/bin/libmcrypt-config /usr/bin/libmcrypt-config


wget -c http://catlnmp.googlecode.com/files/mcrypt-2.6.8.tar.gz
tar zxvf mcrypt-2.6.8.tar.gz
cd mcrypt-2.6.8/
./configure
make
make install
cd ../

安装Google的开源TCMalloc库,提高MySQL在高并发情况下的性能

wget -c http://catlnmp.googlecode.com/files/google-perftools-1.6.tar.gz
tar zxvf google-perftools-1.6.tar.gz
cd google-perftools-1.6/
./configure
make && make install
echo "/usr/local/lib" > /etc/ld.so.conf.d/usr_local_lib.conf
/sbin/ldconfig
cd ../

现在安装mysql

wget -c http://catlnmp.googlecode.com/files/mysql-5.1.50.tar.gz
tar -zxvf mysql-5.1.50.tar.gz
cd mysql-5.1.50
./configure --prefix=/usr/local/mysql --with-extra-charsets=all --enable-thread-safe-client --enable-assembler --with-charset=utf8 --enable-thread-safe-client --with-extra-charsets=all --with-big-tables --with-readline --with-ssl --with-embedded-server --enable-local-infile --without-debug --with-mysqld-ldflags=-ltcmalloc_minimal
make && make install
cd ../
groupadd mysql
useradd -g mysql mysql
cp /usr/local/mysql/share/mysql/my-medium.cnf /etc/my.cnf
/usr/local/mysql/bin/mysql_install_db --user=mysql
chown -R mysql /usr/local/mysql/var
chgrp -R mysql /usr/local/mysql/.
cp /usr/local/mysql/share/mysql/mysql.server /etc/init.d/mysql
chmod 755 /etc/init.d/mysql
chkconfig --level 345 mysql on
echo "/usr/local/mysql/lib/mysql" >> /etc/ld.so.conf
echo "/usr/local/lib" >>/etc/ld.so.conf
ldconfig
ln -s /usr/local/mysql/lib/mysql /usr/lib/mysql
ln -s /usr/local/mysql/include/mysql /usr/include/mysql
service mysql start
/usr/local/mysql/bin/mysqladmin -u root password shinko //你的密码
service mysql restart

接着安装LiteSpeed

wget http://www.litespeedtech.com/packages/4.0/lsws-4.0.16-std-i386-linux.tar.gz
tar zxvf lsws-4.0.16-std-i386-linux.tar.gz
cd lsws-4.0.16
./install.sh

出现–More–(27%)的许可协议,可以直接按空格键或者回车跳到最后.
Do you agree with above license? #这里需要输入Yes (Y要大写)
下面的基本一直回车和选Y就OK了

安装完成就可以访问http://IP:7080来管理LiteSpeed,

最后就是安装php了,在litespeed控制面板选择Compile PHP
然后选择要安装的php版本,我这里选择php5.3.3,然后用以下参数编译

--with-mysql=mysqlnd --with-mysqli=mysqlnd --with-iconv=/usr/local --with-freetype-dir --with-jpeg-dir --with-png-dir --with-zlib --with-libxml-dir=/usr --enable-xml --disable-rpath --enable-bcmath --enable-shmop --enable-sysvsem --enable-inline-optimization --with-curl --with-curlwrappers --enable-mbregex --enable-mbstring --with-mcrypt --with-gd --enable-gd-native-ttf --with-openssl --with-mhash --enable-pcntl --enable-sockets --with-ldap --with-ldap-sasl --with-xmlrpc --enable-zip --enable-soap --enable-ftp --disable-debug --with-gettext --with-openssl

然后下一步,是程序自动下载安装文件,下载完成后继续下一步,就去到安装画面了.在ssh下运行这句语句,

/usr/local/lsws/phpbuild/buildphp_manual_run.sh

等待几分钟就会安装完成了,如果安装失败,请查看log错误…

17 Comments

Add a Comment
  1. CAT 请问这个 和LNMP一样有 那个vhost.sh 文件么? 如果没有 请猫猫 做一个自动新建网站的 vhost.sh

  2. Y要大写 现在才知道 以前被折腾死了

  3. Step 3 : Preparing for building PHP 5.3.3 Binary

    卡在这里 一直不懂

  4. litespeed也有免费的?

    1. 收费版和免费版!

  5. 就是说各种WEB服务器控了。

  6. Warning: date() [function.date]: It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘America/New_York’ for ‘EDT/-4.0/DST’ instead in /home/www/la/index.php on line 208

    请问怎样可以解决?

  7. 囧,你写了两次 –with-extra-charsets=all,我直接复制过去make,结果杯具了 ~

  8. 那个,请问,按照上面安装完mysql,出现 /usr/local/mysql/libexec/mysqld: error while loading shared libraries: libtcmalloc_minimal.so.0: cannot open shared object file: No such file or directory,是怎么了哇?
    我是ubuntu server,进了root弄的 ~

  9. 还是用傻瓜包比较的方便,wamp很简单

  10. 流量上来后 估计就要付费了 , 一般情况下 免费版确实也够用了

    1. @久酷 150个链接…4000+ip的wp博客,高峰时间段,平均都是50左右的链接数而已…..估计顶1WIP都可以…

  11. 啊哈,這東西好像挺好玩的,弄個玩玩。

  12. 请问一下那 phpmyadmin 要怎样安装?

  13. 写了个llmp一键包。。http://www.hostloc.com/thread-89795-1-2.html

Leave a Reply

Your email address will not be published. Required fields are marked *

猫言猫语 © 2007-2014 Frontier Theme