两个方法解决FireFox3中扩展不兼容

Firefox3终 于出正式版了,我也正式从2.0转换到3.0的版本,以前也迫不及待地用过beta版,但是那时很多在Firefox2.0下的扩展插件都不能用,导致每 次装上没两天就卸掉用回到2.0去了(其中又用回RC版=.=),毕竟如果没有那些扩展和插件,用起来的体验会差很多。现在随着3.0正式版的推出,大部分扩展都跟进了,提供了与 3.0对应的版本,但是还有个别插件仍是不能使用.总是出现不兼容的问题.虽然不显示兼容,其实大部分扩展是可以用的,有两个办法可以解决这个问题.

一是修改扩展版本号:

首先将插件下载到本地。FireFox的插件扩展名是,其实是一个zip压缩打包文件,用winrar等可以打开.找到里面的install.rdf文件,可以找到如下内容:

<em:maxVersion>3.0b5pre</em:maxVersion>

将3.0b5pre改成3.0,保存后重新打包插件即可.

二是设置FireFox:

在FireFox3地址栏输入about:config,会出来一个警告页面,不用理他,点击“我保证我会小心”.然后点右键,选择“新建”->“布尔”,创建一个布尔变量extensions.checkCompatibility,值为false,表示不检查扩展插件的兼容性.同样的步骤再创建一个布尔变量extensions.checkUpdateSecurity,值为false,不检查安全更新.重启,OK

7 Comments

Add a Comment
  1. Pingback: waakee.com
  2. 你好 飞豆网 ANGEL M 想与贵站做合作。请与我联系 QQ 604001149

  3. 被人看上了

    soulhuman最后发表的文章–投资状

  4. 难得我现在用的都有FireFox3的版本了。哈哈。之前着实为SuperDragandGo挣扎了很久。

    1. 用Easy DragToGo啊..不仅有强大的拖拽功能,而且还可以自定义鼠标手势啊…

      1. 嗯。我也是在发现Easy后开始用FireFox3的,哈哈。RC1用了没两天就RC2了=。=

  5. 恩,知道了。第二个办法不错

    老N最后发表的文章–blogupp开始付费展示了

Leave a Reply

Your email address will not be published. Required fields are marked *

猫言猫语 © 2007-2014 Frontier Theme